Frame Relay. Backup interface


El objetivo de esta maqueta es:

  • Implementar una red Frame Relay con 2 routers funcionando como switches y utilizando entre ellos el protocolo estándar de señalización NNI (Network-to-Network Interface). 
  • Probar la funcionalidad de respaldar la conectividad a través de la nube Frame Relay mediante la facilidad de respaldo de un interface por otro interface.  Con ello se intenta emular el servicio CVP+ de Telefónica, si bien no es del todo posible dada la imposibilidad de solapar destinos en la rutas Frame Relay.

     En esta maqueta, para no tener dependencia del esquema IP, trabajaremos sin direccionamiento IP definido en los interfaces WAN. Trabajaremos con la facilidad “IP unnumbered” para permitir tráfico IP en la WAN y con routing dinámico a través de EIGRP.


     Para ello se configuran los routers ‘HUBIBM’ y ‘HUBSAB’ como FRAD (Frame Relay Access Device) proporcionando LMI ccitt y clock (2M) a los CPE (Customer Premise Equipment) ‘IBM’ y ‘SAB’.

     El esquema de la solución es el siguiente:


     A continuación detallamos la configuración, sobre routers Cisco, de los nodos de red:
 hostname HUBIBM
!
frame-relay switching
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
! Se habilita el backup
 backup interface Serial0/1
 clockrate 500000
 no fair-queue
 frame-relay lmi-type q933a
 frame-relay intf-type dce
 frame-relay route 100 interface Serial0/2 200
!
interface Serial0/1
 no ip address
 encapsulation frame-relay IETF
 clockrate 500000
 frame-relay lmi-type q933a
 frame-relay intf-type dce
 frame-relay route 101 interface Serial0/2 201
!
interface Serial0/2
 no ip address
 encapsulation frame-relay IETF
 clockrate 2000000
 frame-relay lmi-type q933a
 frame-relay intf-type nni
 frame-relay route 200 interface Serial0/0 100
 frame-relay route 201 interface Serial0/1 101
----------------------------------------------------------------------------------------------
hostname HUBSAB
!
frame-relay switching
!
interface Serial1/0
 no ip address
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay lmi-type q933a
 frame-relay intf-type nni
 frame-relay route 200 interface Serial1/1 300
 frame-relay route 201 interface Serial1/1 301
!
interface Serial1/1
 no ip address
 encapsulation frame-relay IETF
 clock rate 1000000
 frame-relay lmi-type q933a
 frame-relay intf-type dce
 frame-relay route 300 interface Serial1/0 200
 frame-relay route 301 interface Serial1/0 201


     Configuración equipos cliente:

hostname IBM
!
interface FastEthernet0/0
ip address 40.40.40.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache cef
 no ip route-cache
 no fair-queue
 frame-relay lmi-type q933a
!
interface Serial0/0.101 point-to-point
 bandwidth 1000000
 ip unnumbered FastEthernet0/0
 no ip route-cache
 no ip mroute-cache
 no cdp enable
 frame-relay interface-dlci 101  
!
interface Serial0/1
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache cef
 no ip route-cache
 frame-relay lmi-type q933a
!
interface Serial0/1.100 point-to-point
 bandwidth 1000000
 ip unnumbered FastEthernet0/0
 no ip route-cache
 no ip mroute-cache
 no cdp enable
 frame-relay interface-dlci 100  
!
router eigrp 1
 passive-interface FastEthernet0/0
 network 40.40.40.0 0.0.0.255
 auto-summary
---------------------------------------------------------------------------------------------------

hostname SAB
!
Interface Ethernet0/0
ip address 50.50.50.1 255.255.255.0
 half-duplex
!
interface Serial0/1
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type q933a
!
interface Serial0/1.300 point-to-point
 ip unnumbered Ethernet0/0
 frame-relay interface-dlci 300  
!
interface Serial0/1.301 point-to-point
 ip unnumbered Ethernet0/0
 frame-relay interface-dlci 301  
!
router eigrp 1
 passive-interface Ethernet0/0
 network 50.50.50.0 0.0.0.255
 auto-summary


     Veamos el estado del protocolo de routing y las tablas de rutas al tirar el camino principal y provocar el backup:

HUBIBM#sh ip inter brief 
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  unassigned      YES manual up                    up      
Serial0/1                  unassigned      YES NVRAM  standby mode          down    
Serial0/2                  unassigned      YES manual up                    up      


HUBIBM#sh frame-relay route 
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial0/0       100             Serial0/2       200             active
Serial0/1       101             Serial0/2       201             inactive
Serial0/2       200             Serial0/0       100             active
Serial0/2       201             Serial0/1       101             inactive


HUBSAB#sh ip inter brief 
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/0                  unassigned      YES NVRAM  up                    up      
Serial1/1                  unassigned      YES NVRAM  up                    up      
HUBSAB#sh frame-relay route 
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial1/0       200             Serial1/1       300             active
Serial1/0       201             Serial1/1       301             inactive
Serial1/1       300             Serial1/0       200             active
Serial1/1       301             Serial1/0       201             inactive



IBM#sh ip eigrp interfaces 
IP-EIGRP interfaces for process 1


                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/1.100          1        0/0        12       0/10          50           0
Se0/0.101          0        0/0         0       0/10        7866           0


IBM#sh ip eigrp neighbors  
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   50.50.50.1              Se0/1.100         14 00:00:42   12   200  0  25


IBM#sh ip route 
….


     50.0.0.0/24 is subnetted, 1 subnets
D       50.50.50.0 [90/793600] via 50.50.50.1, 18:58:12, Serial0/1.100
     40.0.0.0/24 is subnetted, 1 subnets
C       40.40.40.0 is directly connected, FastEthernet0/0


SAB#sh ip eigrp interfaces 
IP-EIGRP interfaces for process 1


                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/1.300          1        0/0        12       0/15          50           0
Se0/1.301          0        0/0         0       0/15          50           0
SAB#sh ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq Type
                                            (sec)         (ms)       Cnt Num
0   40.40.40.1              Se0/1.300         12 00:02:43   12   200  0  27


SAB#sh ip route 
…..


     50.0.0.0/24 is subnetted, 1 subnets
C       50.50.50.0 is directly connected, Ethernet0/0
     40.0.0.0/24 is subnetted, 1 subnets
D       40.40.40.0 [90/2195456] via 40.40.40.1, 18:29:07, Serial0/1.300


No hay comentarios:

Publicar un comentario

Nota: solo los miembros de este blog pueden publicar comentarios.